Palo Alto Networks Security Advisories / CVE-2012-6590

CVE-2012-6590 Verbose Error Messages

047910
Severity 3.1 · LOW
Attack Vector NETWORK
Attack Complexity HIGH
Privileges Required NONE
User Interaction REQUIRED
Scope UNCHANGED
Confidentiality Impact LOW
Integrity Impact NONE
Availability Impact NONE

Description

Under certain conditions, when unexpected input is provided to the web-based management UI, overly verbose error information is delivered back to the client. This does not directly result in any specific vulnerability, however this information is helpful to an attacker. (Ref #33139)

This issue results in verbose error messages in specific cases, and does not directly result in an exploitable condition or product vulnerability. Overly verbose error messages can be helpful to an attacker looking to collect information on how a system is architected.

This issue affects PAN-OS 4.0.7 and earlier; PAN-OS 3.0.x is not affected.

Product Status

VersionsAffectedUnaffected
PAN-OS 4.0<= 4.0.7>= 4.0.8
PAN-OS 3.0None3.0.*

Severity: LOW

CVSSv3.1 Base Score: 3.1 (CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N)

Weakness Type

CWE-200 Information Exposure

Solution

PAN-OS 4.0.8 and later.

Workarounds and Mitigations

This issue affects the management interface of the device. Security appliance management best practices dictate that the management interface be isolated and strictly limited only to security administration personnel.

© 2020 Palo Alto Networks, Inc. All rights reserved.