Palo Alto Networks Security Advisories / CVE-2012-6591

CVE-2012-6591 Command Injection Vulnerability

047910
Severity 8 · HIGH
Attack Vector NETWORK
Attack Complexity LOW
Privileges Required LOW
User Interaction REQUIRED
Scope UNCHANGED
Confidentiality Impact HIGH
Integrity Impact HIGH
Availability Impact HIGH

Description

A vulnerability exists whereby an authenticated user can inject arbitrary shell commands using the device management command line interface. (Ref #31116)

This vulnerability can result in arbitrary command execution, and can result in total compromise of the device. The attacker must still be an authenticated administrator of the device.

This issue affects PAN-OS 4.0.4 and earlier; PAN-OS 3.1.9 and earlier.

Product Status

VersionsAffectedUnaffected
PAN-OS 4.0<= 4.0.4>= 4.0.5
PAN-OS 3.1<= 3.1.9>= 3.1.10

Severity: HIGH

CVSSv3.1 Base Score: 8 (CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H)

Weakness Type

CWE-78 Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')

Solution

PAN-OS 4.0.5 and later; PAN-OS 3.1.10 and later.

Workarounds and Mitigations

This issue affects the management interface of the device. Security appliance management best practices dictate that the management interface be isolated and strictly limited only to security administration personnel.

© 2020 Palo Alto Networks, Inc. All rights reserved.