Palo Alto Networks Security Advisories / CVE-2012-6598

CVE-2012-6598 Command Injection Vulnerability

047910
Severity 8.4 · HIGH
Attack Vector LOCAL
Attack Complexity LOW
Privileges Required NONE
User Interaction NONE
Scope UNCHANGED
Confidentiality Impact HIGH
Integrity Impact HIGH
Availability Impact HIGH

Description

A vulnerability exists whereby an authenticated user can inject arbitrary shell commands using the device management command line interface. (Ref #33080)

This vulnerability can result in arbitrary command execution, and can result in total compromise of the device.

This issue affects PAN-OS 4.0.7 and earlier; PAN-OS 3.0.x is not affected.

Product Status

VersionsAffectedUnaffected
PAN-OS 4.0<= 4.0.7>= 4.0.8

Severity: HIGH

CVSSv3.1 Base Score: 8.4 (CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)

Weakness Type

CWE-78 Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')

Solution

PAN-OS 4.0.8 and later.

Workarounds and Mitigations

This issue affects the management interface of the device. Security appliance management best practices dictate that the management interface be isolated and strictly limited only to security administration personnel.

© 2020 Palo Alto Networks, Inc. All rights reserved.