Palo Alto Networks Security Advisories / CVE-2017-16878

CVE-2017-16878 Cross Site Scripting in PAN-OS Captive Portal

047910
Severity 6.1 · MEDIUM
Attack Vector NETWORK
Attack Complexity LOW
Privileges Required NONE
User Interaction REQUIRED
Scope CHANGED
Confidentiality Impact LOW
Integrity Impact LOW
Availability Impact NONE

Description

A vulnerability exists in PAN-OS Captive Portal that could allow for a cross-site scripting (XSS) attack to be performed against clients viewing the captive portal page when configured in a certain way. (Ref # PAN-85238 / CVE-2017-16878)

Successful exploitation of this issue may allow an attacker to inject arbitrary javascript or HTML.

This issue affects PAN-OS 8.0.6-h3 and earlier.

Product Status

VersionsAffectedUnaffected
PAN-OS 8.0<= 8.0.6-h3>= 8.0.7

Severity: MEDIUM

CVSSv3.1 Base Score: 6.1 (CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N)

Weakness Type

CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Solution

PAN-OS 8.0.7 and later.

Workarounds and Mitigations

Customers not using the Captive Portal function within PAN-OS are not impacted by this vulnerability.

Acknowledgments

Palo Alto Networks would like to thank Shaun Wheelhouse for reporting this issue to us.
© 2020 Palo Alto Networks, Inc. All rights reserved.