Palo Alto Networks Security Advisories / CVE-2017-3731

CVE-2017-3731 OpenSSL Vulnerability

047910
Severity 7.5 · HIGH
Attack Vector NETWORK
Attack Complexity LOW
Privileges Required NONE
User Interaction NONE
Scope UNCHANGED
Confidentiality Impact NONE
Integrity Impact NONE
Availability Impact HIGH

Description

The OpenSSL library has been found to contain vulnerability CVE-2017-3731. Palo Alto Networks software makes use of the vulnerable library and may be affected. (Ref # PAN-73914 / CVE-2017-3731)

The OpenSSL library in use by PAN-OS is patched on a regular basis.

This issue affects PAN-OS 6.1, PAN-OS 7.0.14 and earlier, PAN-OS 7.1, PAN-OS 8.0

Product Status

VersionsAffectedUnaffected
PAN-OS 8.0None>= 8.0.2
PAN-OS 7.1None>= 7.1.10
PAN-OS 7.0<= 7.0.14>= 7.0.15
PAN-OS 6.1<= 6.1

Severity: HIGH

CVSSv3.1 Base Score: 7.5 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H)

Weakness Type

CWE-125 Out-of-bounds Read

Solution

PAN-OS 7.0.15 and later; PAN-OS 7.1.10 and later; PAN-OS 8.0.2 and later

Workarounds and Mitigations

N/A

© 2020 Palo Alto Networks, Inc. All rights reserved.