Palo Alto Networks Security Advisories / CVE-2017-7218

CVE-2017-7218 Local Privilege Escalation in the Management Web Interface

047910
Severity 7.8 · HIGH
Attack Vector LOCAL
Attack Complexity LOW
Privileges Required LOW
User Interaction NONE
Scope UNCHANGED
Confidentiality Impact HIGH
Integrity Impact HIGH
Availability Impact HIGH

Description

A vulnerability exists in the Management Web Interface that could allow for local privilege escalation. The Management Web Interface does not properly validate specific request parameters which can potentially allow executing code with higher privileges. (Ref # PAN-70426/ CVE-2017-7218)

Successfully exploiting this issue would require an attacker to be authenticated.

This issue affects PAN-OS 7.1.8 and earlier

Product Status

VersionsAffectedUnaffected
PAN-OS 7.1<= 7.1.8>= 7.1.9

Severity: HIGH

CVSSv3.1 Base Score: 7.8 (CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H)

Weakness Type

CWE-20 Improper Input Validation

Solution

PAN-OS 7.1.9 and later

Workarounds and Mitigations

Palo Alto Networks recommends to implement best practice by allowing web interface access only to a dedicated management network. Additionally, restrict the set of IP addresses to a subset of authorized sources that you allow to interact with the management network.

Acknowledgments

Palo Alto Networks would like to thank Christophe Schleypen from NATO Communications and Information Agency for reporting this issue to us.
© 2020 Palo Alto Networks, Inc. All rights reserved.