Palo Alto Networks Security Advisories / CVE-2020-1994

CVE-2020-1994 PAN-OS: Predictable temporary file vulnerability

047910
Severity 4.1 · MEDIUM
Attack Vector LOCAL
Attack Complexity HIGH
Privileges Required HIGH
User Interaction NONE
Scope UNCHANGED
Confidentiality Impact NONE
Integrity Impact HIGH
Availability Impact NONE

Description

A predictable temporary file vulnerability in PAN-OS allows a local authenticated user with shell access to corrupt arbitrary system files affecting the integrity of the system.

This issue affects:

All versions of PAN-OS 7.1 and 8.0;

PAN-OS 8.1 versions earlier than 8.1.13;

PAN-OS 9.0 versions earlier than 9.0.7.

Product Status

PAN-OS

VersionsAffectedUnaffected
9.2>= 9.2.0
9.1>= 9.1.0
9.0< 9.0.7>= 9.0.7
8.1< 8.1.13>= 8.1.13
8.08.0.*
7.17.1.*

Severity: MEDIUM

CVSSv3.1 Base Score: 4.1 (CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:N/I:H/A:N)

Solution

This issue is fixed in PAN-OS 8.1.13, PAN-OS 9.0.7, PAN-OS 9.1.0, PAN-OS 9.2.0, and all later PAN-OS versions.

PAN-OS 8.0 is now end-of-life as of October 31, 2019, and is no longer covered by our Product Security Assurance policies.

PAN-OS 7.1 is on extended support until June 30, 2020, and is only being considered for critical security vulnerability fixes.

Workarounds and Mitigations

Acknowledgements

This issue was found by a customer.

Timeline

Initial publication
© 2020 Palo Alto Networks, Inc. All rights reserved.