Palo Alto Networks Security Advisories / CVE-2020-2027

CVE-2020-2027 PAN-OS: Buffer overflow in authd authentication response

047910
Severity 7.2 · HIGH
Attack Vector NETWORK
Attack Complexity LOW
Privileges Required HIGH
User Interaction NONE
Scope UNCHANGED
Confidentiality Impact HIGH
Integrity Impact HIGH
Availability Impact HIGH

Description

A buffer overflow vulnerability in the authd component of the PAN-OS management server allows authenticated administrators to disrupt system processes and potentially execute arbitrary code with root privileges.

This issue affects:

All versions of PAN-OS 7.1 and PAN-OS 8.0;

PAN-OS 8.1 versions earlier than PAN-OS 8.1.13;

PAN-OS 9.0 versions earlier than PAN-OS 9.0.7.

Product Status

PAN-OS

VersionsAffectedUnaffected
9.1>= 9.1.0
9.0< 9.0.7>= 9.0.7
8.1< 8.1.13>= 8.1.13
8.08.0.*
7.17.1.*

Severity: HIGH

CVSSv3.1 Base Score: 7.2 (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H)

Weakness Type

CWE-121 Stack-based Buffer Overflow

Solution

This issue is fixed in PAN-OS 8.1.13, PAN-OS 9.0.7, PAN-OS 9.1.0, and all later PAN-OS versions.

PAN-OS 8.0 is end-of-life (as of October 31, 2019) and is no longer covered by our Product Security Assurance policies.

PAN-OS 7.1 is on extended support until June 30, 2020, and we are considering updates only for critical security vulnerability fixes.

Workarounds and Mitigations

This issue affects the management interface of PAN-OS and you can mitigate the impact of this issue by following best practices for securing the PAN-OS management interface. Please review the Best Practices for Securing Administrative Access in the PAN-OS technical documentation, available at https://docs.paloaltonetworks.com/best-practices.

Acknowledgments

This issue was found by Nicholas Newsom of Palo Alto Networks during internal security review.

Timeline

Initial publication
© 2020 Palo Alto Networks, Inc. All rights reserved.